The user is unable to proceed processing transaction for a customer due to message appearing (‘This document is currently being processed in a different transaction. Please choose another document.’) when selecting document number.
Cause:
This happens when the last transaction done for the document encountered problem during processing causing the document to be locked in t_acr_lock.
Solution:
- Perform select statement below to verify locking. Check for the doc_no column. The document number should match the document on which the user is encountering problem.select *
from t_acr_lock - Delete the row that is causing the problem. Refer to delete statement below.
declare @cust_code as char(8),
@doc_no as char(8),
@user_id as char(10)set @cust_code = ‘put customer code here’
set @doc_no = ‘put document number here’
set @user_id = ‘put user id here’
– delete row with locked document
delete
from t_acr_lock
where cust_code = @cust_code
and doc_no = @doc_no
and user_id_chg_by = @user_id
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