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Thursday, August 11, 2011

AR Batch CM Processing: Balance cannot be adjusted in Batch CM Processing

Issue:
User is unable to perform CM Processing for particular document number due to amount is zero. When checking Customer A/R Status, there is still balance for the invoice.


Cause:
Column amt_allocated in table a_open_item is not equal to zero. Possible cause is network fluctuation during last transaction.

Solution:
1. Check the following tables if transaction exists:
  • a_doc_reg
  • a_open_item
  • a_open_itm_hist
  • a_output_tax
  • a_ar_gl_trans
Criteria would be customer code and document number.
2. Check amt_allocated in a_open_item table if not equal to zero.
2.1. If amt_allocated is not zero, perform update statement below
declare @cust_code as char(8),
@doc_no as char(8)
set @cust_code = 'cust_code w/ issue'
set @doc_no = 'doc_no w/ issue'
update a_open_item
set amt_allocated = 0
where cust_code = @cust_code
and doc_no = @doc_no
2.2. Else, notify JSI for issue

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