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Monday, July 11, 2011

OEB-CM Processing: Error - 'Customer is currently being processed...'

Issue:
User receives message ‘Customer is currently being processed in Accounts Receivable. Please wait.’ when saving CM Processing.


Cause:
This issue occurs if there is another user using the same customer in Batch Processing. JSI has released patch to address this issue. The message is still there but it now shows which user_id is currently doing a transaction for the customer. This way, the user performing OEB-CM Processing is aware on who uses the customer and instead of contacting IT, he/she would contact the department.

There are times when user performing Batch processing is complete but the person performing CM Processing is still seeing the message. For some reason, the record for the customer in table t_acr_lock is not cleared. If this is the case, perform fix below.

Fix:
  1. Check t_acr_lock for customer with issue to identify which user uses the customer.
  2. Notify user if he/she is currently doing transaction for the customer.
  3. If user is doing transaction, wait for feedback once done.
    If user confirmed that no transactions are done, proceed to step 4.
  4. Update t_acr_lock. Delete record for customer with problem.
  5. Notify requestor that he/she could now perform CM Processing.

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