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Thursday, July 21, 2011

Issuing: Item Suspended

Issue:
User receives 'All items were suspended due to insufficient stock.' message upon performing Issuing transaction. After clicking OK, user Processed Suspended transaction then another message appeared 'There's no suspended item that has been processed because there's no available qty. on hand.'


Cause:
UM balance in a_item_balance (BT) is different from SKU (PC).

Solution:
1. Run query to check tables:
declare @item_no as varchar(20),
@site as char(8)
set @item_no = 'CL0504022'
set @site = 'MLA-D/S'
-- a_item_balance
select qty_alloc_mfg,
qty_alloc_sales,
qty_on_hand,
*
from a_item_balance
where item_number = @item_no
and site = @site
-- a_item_um
select *
from a_item_um
where item_number = @item_no
-- a_item_master
select *
from a_item_master
where item_number = @item_no
2. Below is the update statement to fix issue:
declare @um as char(3),
@item_no as varchar(20),
@ref1 as varchar(15),
@ref2 as varchar(15),
@site as char(8),
@lot_serial1 as varchar(20),
@lot_serial2 as varchar(20)
set @um = 'PC'
@item_no = 'CL0504022'
@ref1 = 'RS044739'
@ref2 = 'RS044744'
@site = 'MLA-D/S'
@lot_serial1 = 'CM143086-SR36734'
@lot_serial2 = 'CM143091-SR36738'
-- update a_item_balance table
update a_item_balance
set um = @um
where item_number = @item_no
and ref in (@ref1, @ref2)
and site = @site
and lot_serial_no in (@lot_serial1, @lot_serial2)

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