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Wednesday, July 20, 2011

Invoice Printing: There are no more orders ready for invoicing

Issue:
User receives message ‘There are no more orders ready for invoicing.’ when performing invoice printing.


Cause:
Table is locked to another user. This type of issue is fixed in the current patch for Invoice printing (External Exe). There are also other reasons for this error. Please see solution to verify.

Solution:
1. Go to SO Tracking (OEB > Inquiry > SO Tracking) to check what transactions the SO had passed thru. Should there be no error here, proceed to next step.
2. Go to SO Entry and retrieve SO with issue. Take note of the SO Type.
3. Go to SO Types (OEB > Tables > Sales Order Types) and check particular SO Type if Print Invoice is checked and also what Invoice format number it uses. If not checked, then this is the cause of the error. Otherwise, proceed to next step.
4. From previous window (Sales Order Types), check if Format is not 1. If Format is not 1 then perform Invoice printing again for the SO then select correct Format. If issue persists, proceed to next step.
5. Check t_oeb_lock table and see if SO Number is locked. Should the SO number exist, take note of the user_id using the SO and proceed to next step. Otherwise, contact JSI for assistance.
6. Check pc_user_def table and filter by user_id noted on previous step in order to get the name of the other user using the SO.
7. Notify user with issue that the error is caused by other user using the same SO and corrective action is to have the other user logout of ERIC then log back in.
8. Once other user logs out of ERIC, user can now perform Invoice printing. Should issue persist, notify JSI for assistance.

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